Выделение группы адресов для NAT

Написал admin . Опубликовано в Network просмотров 2 331

Так себеПойдетХорошоПонравилосьОтличный пост (No Ratings Yet)
Загрузка...

В Mikrotik есть такая замечательная вещь, как возможность группировать коннекшены. Мы воспользуемся этой возможностью, чтобы организовать NAT не на один IP, а на серию.

Для этого мы красим трафик к примеру на три группы (NAT на 3 адреса). Группируем по адресу и порту.

/ip firewall mangle
add action=mark-connection chain=prerouting comment="" disabled=no new-connection-mark=1_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:3/0
add action=mark-connection chain=prerouting comment="" disabled=no new-connection-mark=2_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:3/1
add action=mark-connection chain=prerouting comment="" disabled=no new-connection-mark=3_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:3/2

Теперь эти группы мы можем использовать для NAT — за каждой из групп будет закреплен свой IP.
/ip firewall nat
add action=src-nat chain=srcnat comment="" connection-mark=1_conn disabled=no src-address=YOUR_PRIVATE_SUBNET to-addresses=FIRST_PUBLIC_IP
add action=src-nat chain=srcnat comment="" connection-mark=2_conn disabled=no src-address=YOUR_PRIVATE_SUBNET to-addresses=SECOND_PUBLIC_IP
add action=src-nat chain=srcnat comment="" connection-mark=3_conn disabled=no src-address=YOUR_PRIVATE_SUBNET to-addresses=THIRD_PUBLIC_IP

YOUR_PRIVATE_SUBNET Ваша приватная сетка, которую НАТим
*_PUBLIC_IP Ваши белые адреса

В общем-то и все.

Хочу еще добавить, что в некоторых случаях, этот метод приводит к очень интересным эффектам. К примеру при проигрывании потокового видео с сайта vkontakte.ru, звук шел не от сюжета. С чем это связано — я не знаю 🙂

Похожие статьи:

Метки: ,

Trackback from your site.

Leave a comment